<!DOCTYPE html>
<html lang="fr">
<head>
	<meta charset="UTF-8" />
	<title>Concevoir des formulaires inclusifs &#8211; 24 jours de web</title>
	<link rel="stylesheet" href="https://www.24joursdeweb.fr/wp-content/themes/24jdw2020/style.css" />
	<link rel="alternate" type="application/rss+xml" title="Le flux RSS de 24 jours de web" href="https://www.24joursdeweb.fr/feed/" />
	<meta name="viewport" content="width=device-width, initial-scale=1" />
	<meta name="apple-mobile-web-app-title" content="24j de web" />
		<meta property="og:title" content="Concevoir des formulaires inclusifs" />
	<meta property="og:description" content="24 jours de web : Le calendrier de l&#039;avent des gens qui font le web d&#039;après." />
			<meta property="og:image" content="https://www.24joursdeweb.fr/wp-content/themes/24jdw2020/images/og.jpg" />
	<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="24 jours de web &raquo; Concevoir des formulaires inclusifs Flux des commentaires" href="https://www.24joursdeweb.fr/2020/concevoir-des-formulaires-inclusifs/feed/" />
<link rel='stylesheet' id='prismCSS-css'  href='https://www.24joursdeweb.fr/wp-content/themes/24jdw2020/css/prism.css?ver=4.9.16' type='text/css' media='all' />
<script type='text/javascript' src='https://www.24joursdeweb.fr/wp-content/themes/24jdw2020/js/prism.js?ver=4.9.16'></script>
<link rel='https://api.w.org/' href='https://www.24joursdeweb.fr/wp-json/' />
<link rel='prev' title='Préparez et donnez votre premier talk' href='https://www.24joursdeweb.fr/2020/preparez-et-donnez-votre-premier-talk/' />

<link rel='shortlink' href='https://www.24joursdeweb.fr/?p=4852' />
<link rel="alternate" type="application/json+oembed" href="https://www.24joursdeweb.fr/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.24joursdeweb.fr%2F2020%2Fconcevoir-des-formulaires-inclusifs%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.24joursdeweb.fr/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.24joursdeweb.fr%2F2020%2Fconcevoir-des-formulaires-inclusifs%2F&#038;format=xml" />
</head>
<body class="post-template-default single single-post postid-4852 single-format-standard edition--2020">
	<div class="site">
				<header class="header">
			<div class="header-content">
				<a href="https://www.24joursdeweb.fr" class="header-logo"><img src="https://www.24joursdeweb.fr/wp-content/themes/24jdw2020/images/header/2020/logo.svg" width="160" height="60" alt="24 jours de web" title="" /></a>
				<a href="https://www.24joursdeweb.fr/2020/" class="header-archive" aria-label="Retour &agrave; l'&eacute;dition 2020"><span class="header-archive-year">2020</span></a>
			</div>
		</header>
				<main role="main" class="main">
<article class="post">
	<header class="post-header">
				<h1 class="post-title">Concevoir des formulaires inclusifs</h1>
				<div class="post-aside post-aside--start">
			<p class="post-metas">
				<span class="post-meta post-meta--author">Anne-Sophie Tranchet</span>
				<time class="post-meta post-meta--date" datetime="2020-12-12T00:00:33+00:00">12 décembre 2020</time>
				<span class="post-meta post-meta--length"><span aria-label="Temps de lecture&nbsp;: environ">~</span>&nbsp;10 minutes</span>
			</p>
		</div>
		<div class="post-aside post-aside--end">
			<p class="post-meta post-meta--share">Partager&nbsp;: <a class="post-share-link post-share-link--facebook" href="https://www.facebook.com/sharer.php?u=https://www.24joursdeweb.fr/2020/concevoir-des-formulaires-inclusifs/" title="Partager cet article sur Facebook" onClick="_gaq.push(['_trackEvent', 'Partage', 'Partager sur Facebook', '']);">Facebook</a><a class="post-share-link post-share-link--twitter" href="http://www.twitter.com/share?text=Concevoir des formulaires inclusifs (via @24joursdeweb)&url=https://www.24joursdeweb.fr/2020/concevoir-des-formulaires-inclusifs/" title="Partager cet article sur Twitter" onClick="_gaq.push(['_trackEvent', 'Partage', 'Partager sur Twitter', '']);">Twitter</a></p>
						<p class="post-meta post-meta--comments">
				<a class="post-comments-link" href="#commentaires" onClick="_gaq.push(['_trackEvent', 'Anchor Link', 'Commentaires', '']);"><u>Commentaires</u> (2)</a>
			</p>
					</div>
	</header>
	<div class="post-entry">
		<p>Il n’existe rien de plus énervant, quand on remplit un formulaire, que de constater qu’on a été oublié. Pour moi, c’est quand on me dit qu’il y a une erreur dans mon prénom (il contient un tiret), ou bien quand mon adresse n’est pas reconnue (elle ne contient pas de voirie). C’est agaçant, mais globalement pas dramatique. Mais je pense aussi à :</p>
<ul>
<li>Felipe, né à l’étranger, à qui on demande souvent le département de naissance.</li>
<li>Youssef, marié et qui a pris le nom de famille de sa femme Nadège.</li>
<li>Lydie et Jessica, les deux mamans d’Alix.</li>
<li>Lina, d’origine Corse, dont le numéro de sécurité sociale contient 2B.</li>
<li>Raphaël, né intersexe et à qui on a assigné le sexe féminin à la naissance. Il est en plein changement administratif.</li>
<li>Hasan, qui vient d’arriver en France. Son numéro de sécurité sociale commence par 8 car il est en cours d’immatriculation.</li>
<li>Angélique, qui a gardé son nom de jeune fille après s’être mariée.</li>
<li>Olivier, dont le numéro de téléphone commence par 07, et Cyril qui n’a pas de téléphone.</li>
<li>Ariel, qui vient d’un pays où le sexe administratif n’est pas limité à deux options.</li>
<li>Tristan, dont les responsables légaux ne sont pas ses parents mais ses grands-parents, Cathy et Lionel.</li>
</ul>
<p>Pour elleux, les implications de formulaires mal conçus sont souvent bien plus coûteuses, en prise de tête, en temps et en stress.</p>
<p>Concevoir un produit de manière inclusive, c&rsquo;est <b>prendre en compte la diversité des utilisatrices et utilisateurs</b>, peut importe leur origine, sexe, genre, religion, capacités physiques, orientation sexuelle, nationalité, capacités mentales, composition familiale, niveau socio-économique, langue natale, etc.</p>
<p>Le design inclusif s’étend évidemment à tous les niveaux de conception. Dans cet article, je m’intéresse particulièrement aux formulaires. En avant pour quelques conseils pratiques !</p>
<div class="section">
<h2>Poser les bonnes questions</h2>
<h3>Comprendre quelle information est nécessaire</h3>
<p>Rentrons dans le vif du sujet avec un grand classique : les questions démographiques, notamment celles autour du genre et du sexe. Ce sont des questions particulièrement intrusives, qui doivent être pensées avec soin.</p>
<p>Pour de nombreuses personnes, la question du sexe ne pose pas de problèmes particuliers mais pour d’autres, c’est très différent. Une personne transgenre devra réfléchir longuement à la question : est-ce qu’elle doit renseigner le sexe affiché sur son état civil (par exemple, pour une livraison, où quelqu’un lui demandera des papiers d’identités) ? Son genre (qui peut être différent de celui indiqué sur ses papiers officiels) ? Des organes génitaux qu’elle possède (pour un service médical) ?</p>
<p>Il existe pourtant de nombreuses autres manières de faire, selon les besoins :</p>
<ul>
<li>Certains préfèrent la formulation <i>« Je suis… »</i> pour éviter le piège entre genre et sexe ; et en proposant suffisamment d’options pour que tout le monde se sente inclus.</li>
<li>D’autres produits vont poser deux questions : celle du genre, puis éventuellement celle des pronoms.</li>
<li>D’autres vont directement au but : <i>« Comment pouvons nous nous adresser à vous ? ».</i></li>
</ul>
<p><img class="size-medium wp-image-5019 aligncenter" src="https://media.24joursdeweb.fr/2020/11/1-form-genre-430x235.png" alt="" width="430" height="235" srcset="https://media.24joursdeweb.fr/2020/11/1-form-genre-430x235.png 430w, https://media.24joursdeweb.fr/2020/11/1-form-genre-768x420.png 768w, https://media.24joursdeweb.fr/2020/11/1-form-genre-860x471.png 860w, https://media.24joursdeweb.fr/2020/11/1-form-genre.png 912w" sizes="(max-width: 430px) 100vw, 430px" /></p>
<p class="wp-caption-text"><i>Dans le parcours d’inscription d’OkCupid, les usagers peuvent choisir « Je suis une femme », « Je suis un homme », ou cliquer sur « Plus d’options » pour dérouler 22 options définies après </i><a href="https://www.okcupid.com/identity/genderfluid"><i>enquête auprès des personnes utilisant le service</i></a><i>.</i></p>
<p><img class="size-full wp-image-5020 aligncenter" src="https://media.24joursdeweb.fr/2020/11/2-form-pronoms.png" alt="F" width="417" height="187" /></p>
<p class="wp-caption-text"><i>Facebook propose trois genres : Femme, Homme et Personnalisé. Le choix personnalisé offre la possibilité de choisir ses pronoms (Elle, Il et Neutre) </i></p>
<p><img class="size-medium wp-image-5021 aligncenter" src="https://media.24joursdeweb.fr/2020/11/3-form-appelation-397x430.png" alt="" width="397" height="430" srcset="https://media.24joursdeweb.fr/2020/11/3-form-appelation-397x430.png 397w, https://media.24joursdeweb.fr/2020/11/3-form-appelation.png 474w" sizes="(max-width: 397px) 100vw, 397px" /></p>
<p class="wp-caption-text"><i>Sur Blablacar, les usagers peuvent choisir d’être appelés Mme, M. ou « Je ne préfère pas le dire ». Dommage que cette troisième option considère que la personne soit du genre Masculin, sans la prévenir.</i></p>
<p>Pour aller plus loin, Romy Duhem-Verdière revient sur les confusions les plus courantes autour du genre, de la civilité et du sexe dans son article <a href="http://romy.tetue.net/pourquoi-la-civilite">Pourquoi la « civilité » ?</a>.</p>
<h3>Choisir le bon type de champ</h3>
<p><img class="size-medium wp-image-5022 aligncenter" src="https://media.24joursdeweb.fr/2020/11/4-form-liste-métiers.png" alt="" width="430" height="248" srcset="https://media.24joursdeweb.fr/2020/11/4-form-liste-métiers.png 779w, https://media.24joursdeweb.fr/2020/11/4-form-liste-métiers-430x248.png 430w, https://media.24joursdeweb.fr/2020/11/4-form-liste-métiers-768x444.png 768w" sizes="(max-width: 430px) 100vw, 430px" /></p>
<p class="wp-caption-text"><i>Sur le formulaire de pré-plainte du site du Ministère de l’Intérieur, un menu déroulant propose 1104 (!) métiers (dont typographe, propriétaire de haras, archevêque ou amiral) mais aucun métiers du design.</i></p>
<p>La manière de demander une information à l’utilisateur a un impact sur son expérience :</p>
<ul>
<li>Un champ structuré (menu déroulant, cases à cocher, radio boutons à sélectionner, attribut <code>autocomplete</code>) facilite la saisie. Mais il présente aussi un risque de ne proposer aucune option pertinente à l’usager.</li>
<li>Un champ libre est assuré de convenir à tout le monde. Par contre, la saisie peut être plus difficile.</li>
<li>Souvent, la combinaison d&rsquo;un champ structuré et d&rsquo;un champ libre permet d&rsquo;associer le meilleur des deux mondes !</li>
</ul>
<p>Le libellé permettant d’accéder au champ libre devra par contre être choisi avec soin. Pour une donnée personnelle (le genre, la religion, les origines…), on évite l’intitulé « Autre ». Personne n&rsquo;aime être considéré comme « en dehors de la normalité »…</p>
<p><img class="size-medium wp-image-5023 aligncenter" src="https://media.24joursdeweb.fr/2020/11/5-form-autre-430x111.png" alt="" width="430" height="111" srcset="https://media.24joursdeweb.fr/2020/11/5-form-autre-430x111.png 430w, https://media.24joursdeweb.fr/2020/11/5-form-autre.png 751w" sizes="(max-width: 430px) 100vw, 430px" /></p>
<p class="wp-caption-text"><em>À propos du logement, le site de la MAÏF propose les deux choix les plus communs (</em>Maison et Appartement<em>) ainsi qu’un choix Autre.</em></p>
<p><img class="size-medium wp-image-5024 aligncenter" src="https://media.24joursdeweb.fr/2020/11/6-form-plus-doptions-430x235.png" alt="" width="430" height="235" srcset="https://media.24joursdeweb.fr/2020/11/6-form-plus-doptions-430x235.png 430w, https://media.24joursdeweb.fr/2020/11/6-form-plus-doptions-768x420.png 768w, https://media.24joursdeweb.fr/2020/11/6-form-plus-doptions-860x471.png 860w, https://media.24joursdeweb.fr/2020/11/6-form-plus-doptions.png 912w" sizes="(max-width: 430px) 100vw, 430px" /></p>
<p class="wp-caption-text"><i>Sur OkCupid, la liste des choix complémentaires est derrière le bouton « Plus d’options ».</i></p>
<h3>Limiter les champs obligatoires</h3>
<p>Si une donnée n&rsquo;est pas indispensable au service, elle ne doit pas être obligatoire. Forcer la réponse à une question serait contre-productif :</p>
<ul>
<li>Cela augmente le risque de faire fuir des usagers ;</li>
<li>Les réponses risquent d’être incorrectes (je vous invite à compter le nombre de personnes avec le numéro de téléphone 0123456789 dans votre base de données…)</li>
</ul>
<p><img class="size-medium wp-image-5025 aligncenter" src="https://media.24joursdeweb.fr/2020/11/7-form-champs-nombreux-430x233.png" alt="" width="430" height="233" srcset="https://media.24joursdeweb.fr/2020/11/7-form-champs-nombreux-430x233.png 430w, https://media.24joursdeweb.fr/2020/11/7-form-champs-nombreux-768x417.png 768w, https://media.24joursdeweb.fr/2020/11/7-form-champs-nombreux-860x466.png 860w, https://media.24joursdeweb.fr/2020/11/7-form-champs-nombreux.png 955w" sizes="(max-width: 430px) 100vw, 430px" /></p>
<p class="wp-caption-text"><i>Pour télécharger un modèle de masque sur l’AFNOR, il faut remplir sept champs, ainsi que trois cases à cocher. C’est ce qu’on appelle un formulaire intrusif.</i></p>
<h3>Donner la portée de l&rsquo;information</h3>
<p><img class="size-medium wp-image-5026 aligncenter" src="https://media.24joursdeweb.fr/2020/11/8-form-piece-didentité-430x133.png" alt="" width="430" height="133" srcset="https://media.24joursdeweb.fr/2020/11/8-form-piece-didentité-430x133.png 430w, https://media.24joursdeweb.fr/2020/11/8-form-piece-didentité.png 580w" sizes="(max-width: 430px) 100vw, 430px" /></p>
<p class="wp-caption-text"><i>Sur le site de Airbnb, un texte d’aide précise que les champs Nom et Prénom doivent « correspondre aux informations figurant sur la pièce d’identité »</i></p>
<p><img class="size-full wp-image-5027 aligncenter" src="https://media.24joursdeweb.fr/2020/11/9-form-portée-champ.png" alt="" width="340" height="106" /></p>
<p class="wp-caption-text"><i>Sur le site de Winamax, il est précisé que le nom de joueur est « le nom que les autres joueurs verront ».</i></p>
<p>En effet, pour les questions personnelles, il est important de préciser l’usage qui sera fait de la donnée :</p>
<ul>
<li>Sera-t-elle transmise à un service tiers ? (comme c’est le cas pour les numéros de téléphones transmis aux transporteurs)</li>
<li>Sera-t-elle affichée publiquement ? (l’usager veut-il donner son nom de famille ou son lieu d’habitation dans ce cas ?)</li>
<li>Sera-t-elle utilisée à des fins statistiques ou promotionnelles ?</li>
</ul>
<p>En étant transparent sur ces éléments, les usagers seront rassurés et donc plus enclins à répondre de manière adaptée.</p>
</div>
<h2>Utiliser un langage inclusif et accessible</h2>
<h3>Dé-masculiniser la langue</h3>
<p><img class="size-medium wp-image-5028 aligncenter" src="https://media.24joursdeweb.fr/2020/11/10-form-inclusif-430x110.png" alt="" width="430" height="110" srcset="https://media.24joursdeweb.fr/2020/11/10-form-inclusif-430x110.png 430w, https://media.24joursdeweb.fr/2020/11/10-form-inclusif.png 712w" sizes="(max-width: 430px) 100vw, 430px" /></p>
<p class="wp-caption-text"><i>Dans l’interface de Alan, les textes sont écrits en utilisant la variante (e) de l’écriture inclusive. </i></p>
<p>Avoir une posture d’inclusion c’est aussi faire attention aux choix des mots, via des formulations neutres, l’utilisation de termes épicènes, etc.</p>
<p>De précieuses ressources existent à ce sujet, par exemple :</p>
<ul>
<li><a href="https://www.24joursdeweb.fr/2017/ecriture-inclusive-faisons-le-point-autour-de-la-cheminee/">Écriture inclusive : faisons le point autour de la cheminée</a></li>
<li><a href="https://www.cairn.info/revue-travail-genre-et-societes-2018-1-page-219.htm">Non, le masculin ne l’emporte pas sur le féminin</a></li>
</ul>
<h3>Éliminer le jargon</h3>
<p>Écrire de manière simple et claire est un levier fort pour un formulaire plus inclusif. Cela profitera :</p>
<ul>
<li>aux populations en situation d&rsquo;illectronisme (<a href="https://blog.hello-bokeh.fr/2020/07/20/litteratie-et-illectronisme-en-france/">une personne sur cinq a du mal à lire un texte simple</a>) ;</li>
<li>aux personnes dont le français n&rsquo;est pas la langue maternelle ;</li>
<li>aux personnes souffrant de troubles cognitifs ou d&rsquo;apprentissages ;</li>
<li>aux gens pressés, à ceux interrompus régulièrement ;</li>
<li>et finalement… à tous les usagers !</li>
</ul>
<p>Expliquer des notions complexes avec des termes simples améliore l’expérience de tout le monde. Les utilisateurs du service peuvent alors faire un choix éclairé, sans connaissances préalables.</p>
<p><img class="size-medium wp-image-5029 aligncenter" src="https://media.24joursdeweb.fr/2020/11/11-form-jargon-418x430.png" alt="" width="418" height="430" srcset="https://media.24joursdeweb.fr/2020/11/11-form-jargon-418x430.png 418w, https://media.24joursdeweb.fr/2020/11/11-form-jargon.png 535w" sizes="(max-width: 418px) 100vw, 418px" /></p>
<p class="wp-caption-text"><i>Sur le site Alan, le concept de « calcul de la prévoyance d’une assurance santé » est expliqué de manière simple et est illustré par un simulateur.</i></p>
<h3>Être explicite</h3>
<p>De nombreux produits cherchent à se démarquer par un <a href="https://www.nngroup.com/articles/tone-of-voice-dimensions/">tone of voice</a> unique. Pourtant, les jeux de mots nuisent à la compréhension pour un certain nombre :</p>
<ul>
<li>les personnes qui n’ont pas le bagage culturel nécessaire ;</li>
<li>celles naviguant sur Internet avec une plage braille ou un lecteur d’écran, qui n&rsquo;auront pas une vue d&rsquo;ensemble de la page ;</li>
<li>les personnes neuro-atypiques sur le spectre autistique, qui ne sont pas toujours à l&rsquo;aise avec les métaphores ou le sarcasme.</li>
</ul>
<p><img class="size-medium wp-image-5030 aligncenter" src="https://media.24joursdeweb.fr/2020/11/12-form-blagues-430x284.png" alt="" width="430" height="284" srcset="https://media.24joursdeweb.fr/2020/11/12-form-blagues-430x284.png 430w, https://media.24joursdeweb.fr/2020/11/12-form-blagues.png 569w" sizes="(max-width: 430px) 100vw, 430px" /></p>
<p class="wp-caption-text"><i>Sur BackMarket, le bouton d’inscription au service est peu explicite. Son libellé, « Enchantés ! », risque d&rsquo;être incompris de certaines personnes.</i></p>
<div class="section">
<h2>Valider la donnée</h2>
<p>J&rsquo;ai demandé autour de moi quels problèmes d&rsquo;inclusivité les gens avaient déjà rencontré. Plus de la moitié des réponses que j’ai obtenues étaient des erreurs de validation. Fréquemment, des réponses sont considérées comme invalides syntaxiquement, à tort.</p>
<p>Les usagers doivent alors choisir entre deux stratégies :</p>
<ul>
<li>Renseigner le formulaire de manière incorrecte « pour que ça passe ».</li>
<li>Abandonner l’utilisation du produit par dépit, ou parce que le service leur devient inaccessible.</li>
</ul>
<p><img class="size-medium wp-image-5031 aligncenter" src="https://media.24joursdeweb.fr/2020/11/13-form-erreur-430x68.png" alt="" width="430" height="68" srcset="https://media.24joursdeweb.fr/2020/11/13-form-erreur-430x68.png 430w, https://media.24joursdeweb.fr/2020/11/13-form-erreur.png 652w" sizes="(max-width: 430px) 100vw, 430px" /></p>
<p class="wp-caption-text"><i>Chez Boulanger, les caractères ( ) &gt; &lt; ; sont interdits. Et visiblement, les tirets aussi puisque c’est le seul caractère non alphanumérique présent dans le champ.</i></p>
<p>Comprendre ce qu&rsquo;est une donnée valide n&rsquo;est pas toujours aisé. Les cas simples sont faciles à identifier mais l&rsquo;exclusion vient souvent des cas auxquels on ne pense pas :</p>
<ul>
<li>Bien que contenant des caractères spéciaux, Andreï Lintşu, Mélina Sánchez et Loïc De L&rsquo;Abresle sont des noms aussi valides que Emma Legrand et Julien Lacombe.</li>
<li>Un email peut comporter des caractères spéciaux (« + »), une extension de domaine longue (« .museum ») ou plusieurs points dans le nom de domaine ( « .gouv.fr »).</li>
<li>Une adresse n&rsquo;a pas toujours un numéro ou une voirie.</li>
<li>De <a href="https://en.wikipedia.org/wiki/Legal_recognition_of_non-binary_gender">nombreux pays</a> reconnaissent officiellement les personnes inter-sexes ou non-binaires.</li>
<li>Un numéro de téléphone portable ne commence pas toujours par 06.</li>
<li>Le numéro de sécurité sociale peut contenir des lettres (pour les personnes nées en Corse notamment).</li>
<li>Une personne peut n’avoir qu’un seul parent</li>
<li>Etc.</li>
</ul>
<p>Pour chaque champ, il est donc important de se documenter pour aller au delà de ses propres biais :</p>
<ul>
<li><a href="https://www.w3.org/International/questions/qa-personal-names">Noms de personnes à travers le monde</a> recense les différences culturelles autour du nom.</li>
<li><a href="https://github.com/kdeldycke/awesome-falsehood">Awesome Falshood</a> regroupe de nombreuses listes d&rsquo;idées reçues (mails, numéros de téléphones, adresses…).</li>
<li>Le <a href="https://consciousstyleguide.com/">Conscious Style Guide</a> couvre de nombreux sujets (orientation sexuelle, appartenance religieuse…)</li>
</ul>
<p>Enfin, quel sera l’impact d’une donnée fausse (ou incomplète) pour les usagers du service ? Restera-t-il accessible ? Si la donnée doit effectivement être validée, il existe des méthodes plus efficaces (et moins excluantes) que la validation syntaxique. Pour l&#8217;email ou le numéro de téléphone, on peut envoyer un code de vérification par exemple.</p>
</div>
<h2>Donner des indications accessibles</h2>
<p>Les messages de confirmations ou d’erreurs doivent être affichés dans un ordre linéaire :</p>
<ol>
<li>le label du champ ;</li>
<li>les instructions d’aides à la saisie et/ou les erreurs éventuelles ;</li>
<li>le champ en lui-même.</li>
</ol>
<p>Les personnes utilisant un lecteur d’écran ou une plage braille auront ainsi tout le contexte nécessaire pour remplir le champ.</p>
<p>De la même manière, les messages d’erreurs doivent être indiqués de manière explicite et pas seulement par la couleur.</p>
<p><img class="size-full wp-image-5032 aligncenter" src="https://media.24joursdeweb.fr/2020/11/14-form-aide.png" alt="" width="401" height="119" /></p>
<p class="wp-caption-text"><i>Dans l’interface d’administration de Kirby, les textes d’aide sont situés en dessous du champ. Une personne utilisant un lecteur d’écran en aura connaissance trop tard, après avoir rempli le champ.</i></p>
<p><img class="size-medium wp-image-5033 aligncenter" src="https://media.24joursdeweb.fr/2020/11/15-form-description-430x111.png" alt="" width="430" height="111" srcset="https://media.24joursdeweb.fr/2020/11/15-form-description-430x111.png 430w, https://media.24joursdeweb.fr/2020/11/15-form-description.png 543w" sizes="(max-width: 430px) 100vw, 430px" /></p>
<p class="wp-caption-text"><i>Sur le site de l’AGEFIPH, le texte d’aide est situé avant le champ. Dommage que ça soit pour prévenir l’utilisateur qu’une limitation syntaxique n’ayant aucun sens soit en place…</i></p>
<div class="section">
<h2>En conclusion</h2>
<p><b>Concevoir des formulaires inclusifs c’est s&rsquo;adapter aux personnes et ne pas demander aux personnes de s&rsquo;adapter au produit.</b></p>
<p>Ainsi, les usagers seront compris et valorisés, les données gagneront en qualité et le produit bénéficiera d&rsquo;une image positive. Yay &#x1f389; !</p>
</div>
<div class="footnotes">
<h2>Pour aller plus loin</h2>
<ul>
<li>Le guide <a href="https://service-manual.nhs.uk/content/how-to-write-good-questions-for-forms">How to write good questions for forms</a> du NHS (National Health Service britannique)</li>
<li>L’excellent livre <b>Technically Wrong: Sexist Apps, Biased Algorithms, and Other Threats of Toxic Tech</b> de <a href="https://www.sarawb.com/books">Sara Wachter-Boettcher</a></li>
<li>La présentation <a href="https://www.youtube.com/watch?v=eJb3xYNcTzw">Comment les logiciels pourrissent ma vie</a> et <a href="https://docs.google.com/presentation/d/17vx3lk_PiBE9EEdP9nRqo7MOlYe22oj4WBDQsiOChVs/edit#slide=id.p">Inclure les minorités sexuelles dans son design</a> par Antonin Le Mée.</li>
<li>Le thread Twitter <a href="https://twitter.com/liatrisbian/status/1281978736318001152?s=20">« A few easy things you can do to make your next product a bit more inclusive for trans and non-binary people »</a> par <a href="https://fossheim.io/">Sarah L. Fossheim</a></li>
<li>La présentation <a href="https://slides.com/tatianamac/socially-inclusive-design-systems/fullscreen">Building Socially-Inclusive Design Systems</a> de Tatiana Mac</li>
<li><a href="https://www.surveymonkey.com/curiosity/how-to-create-more-inclusive-surveys/">How to create more inclusive surveys</a> sur le blog de SurveyMonkey</li>
<li><a href="https://www.invisionapp.com/inside-design/writing-accessible-microcopy/">7 guidelines for writing accessible microcopy</a></li>
</ul>
<p><em>Merci à Gladys pour la relecture et ses retours précieux.</em></p>
</div>
	</div>
		<footer class="post-footer">
		<div class="post-author">
			<div class="post-author-avatar">
				<img src="https://media.24joursdeweb.fr/2020/12/anne-sophie.jpg" alt="Anne-Sophie Tranchet" width="150" height="150" />			</div>
			<div class="post-author-text">
				<div class="post-author-text-content">
					<h2 class="post-author-title">&Agrave; propos de Anne-Sophie Tranchet</h2>
					<p class="post-author-description"><a href="http://www.hello-bokeh.fr" />UX/UI Designer indépendante et engagée</a>, je suis spécialisée dans le design de service public, pour des produits inclusifs et accessibles à toutes et tous. Passionnée, je forme et je sensibilise régulièrement sur l'UX Design ou l'accessibilité.

Le reste du temps, je lis des livres ou je cause féminisme <a href="https://www.twitter.com/annso_" />sur twitter</a>.</p>
				</div>
			</div>
		</div>
	</footer>
	</article>
	<div class="posts-nav">
		<span class="posts-nav-link posts-nav-previous"><a href="https://www.24joursdeweb.fr/2020/preparez-et-donnez-votre-premier-talk/" rel="prev"><span class="posts-nav-date">Article pr&eacute;c&eacute;dent&nbsp;:</span><span class="posts-nav-title">Préparez et donnez votre premier talk</span></a></span>	</div>
	<div class="comments" id="commentaires">
			<h2 class="comments-title">
			2 commentaires sur cet article		</h2>
		<ol class="comments-list">
							<li class="comment-item" id="comment-209940">
					<div class="comment-avatar" aria-hidden="true"><span>K</span></div>
					<div class="comment-body">
						<p class="comment-meta"><strong class="comment-author"><a href='https://kimlaitrinh.me' rel='external nofollow' class='url'>Kim Laï</a></strong>, le <span class="comment-date">samedi 12 décembre 2020 à 09:17</span></p>
						<div class="comment-entry">
							<p>Super article, complément parfait du celui du 3 décembre :)</p>
						</div>
												<div class="comment-reply">
													</div>
											</div>
				</li>
			  				<li class="comment-item" id="comment-209941">
					<div class="comment-avatar" aria-hidden="true"><span>E</span></div>
					<div class="comment-body">
						<p class="comment-meta"><strong class="comment-author">Emmanuelle</strong>, le <span class="comment-date">samedi 12 décembre 2020 à 09:48</span></p>
						<div class="comment-entry">
							<p>Bonjour Anne-Sophie,</p>
<p>Je vous remercie pour cet article très intéressant.</p>
<p>Je voudrais rebondir cette phrase si juste : « Les réponses risquent d’être incorrectes (je vous invite à compter le nombre de personnes avec le numéro de téléphone 0123456789 dans votre base de données…) ».</p>
<p>C’est tellement vrai. Je fais partie des personnes qui renseignent ce faux numéro de téléphone car étant sourde, je ne peux pas répondre au téléphone.<br />
J’aimerais bien que ce champ ne soit pas obligatoire quand on renseigne déjà son adresse e-mail comme moyen de contact.<br />
S’il faut renseigner son numéro de téléphone, expliquer pourquoi. Si c’est pour la double authentification, je comprendrais qu’il faut mettre son numéro de téléphone mais si c’est pour nous dire qu’il y a un problème avec la commande par exemple, il faut plutôt passer par le mail plutôt que par le téléphone.</p>
<p>Passez une bonne journée,<br />
Emmanuelle.</p>
						</div>
												<div class="comment-reply">
													</div>
											</div>
				</li>
			  		</ol>
			<div class="comments-publish">
		<h2 class="comments-title">Laisser un commentaire </h2>
		<form action="https://www.24joursdeweb.fr/wp-comments-post.php" method="post" class="comment-form">
							<div class="comment-field comment-field--row">
					<label class="comment-label" for="comment-author">Nom&nbsp;:</label>
					<input class="comment-textbox" type="text" name="author" id="comment-author" value="" size="22" tabindex="1" required="required" />
				</div>
				<div class="comment-field comment-field--row">
					<label class="comment-label" for="comment-email">E-mail&nbsp;:</label>
					<input class="comment-textbox" type="email" name="email" id="comment-email" value="" size="22" tabindex="2" required="required" />
				</div>
				<div class="comment-field comment-field--row">
					<label class="comment-label" for="comment-url">Site web <em>(facultatif)</em>&nbsp;:</label>
					<input class="comment-textbox" type="url" name="url" id="comment-url" value="" size="22" tabindex="3" />
				</div>
						<div class="comment-field comment-field--column">
				<label class="comment-label" for="comment">Votre commentaire&nbsp;:</label>
				<textarea class="comment-textarea" name="comment" id="comment" cols="80" rows="5" tabindex="4" required="required"></textarea>
			</div>
			<div class="comment-actions">
				<input class="comment-button" name="submit" type="submit" id="submit" tabindex="5" value="Poster mon commentaire" />
				<input type="hidden" name="comment_post_ID" value="4852" />
			</div>
			<p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="e67ed33ce3" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="116"/></p>		</form>
		<p class="comment-warning">Les commentaires sont mod&eacute;r&eacute;s manuellement. Merci de respecter&nbsp;: la personne qui a &eacute;crit l'article, les autres participant(e)s &agrave; la discussion, et la langue fran&ccedil;aise. Vous pouvez <a href="https://www.24joursdeweb.fr/2020/concevoir-des-formulaires-inclusifs/feed">suivre les r&eacute;ponses par flux RSS</a>.</p>
	</div>
	</div>		</main>
				<footer class="footer">
			<div class="footer-content">
				<div class="footer-column footer-column--logo">
					<a href="https://www.24joursdeweb.fr" class="footer-logo"><img class="footer-logo-img" src="https://www.24joursdeweb.fr/wp-content/themes/24jdw2020/images/footer/logo.png" alt="24 jours de web" /></a>
				</div>
				<div class="footer-column footer-column--text">
					<p class="footer-baseline"><b>24 jours de web</b>, le calendrier de l&rsquo;avent des gens qui font le web d&rsquo;après.</p>
					<p>2012-2020, tous droits r&eacute;serv&eacute;s.</p>
						<p>
		Illustration 2020 par <a href="https://www.instagram.com/maela_cosson/">Ma&euml;la Cosson</a>.
	</p>
				</div>
				<div class="footer-column footer-column--links">
					<ul class="footer-links">
						<li><a href="https://www.24joursdeweb.fr/a-propos/">&Agrave; Propos</a></li>
						<li><a href="https://www.24joursdeweb.fr/mentions-legales/">Mentions l&eacute;gales</a></li>
						<li><a href="https://www.24joursdeweb.fr/remerciements/">Remerciements</a></li>
						<li><a href="https://github.com/hteumeuleu/24jdw/issues">Signaler un probl&egrave;me</a></li>
						<li class="footer-link--twitter"><a href="https://www.twitter.com/24joursdeweb">@24joursdeweb sur Twitter</a></li>
					</ul>
				</div>
				<div class="footer-archives">
					<strong class="footer-archives-title">24 jours d&rsquo;archives</strong>
					<ul class="footer-archives-links">
						<li><a href="https://www.24joursdeweb.fr/2019/">&Eacute;dition 2019</a></li>
						<li><a href="https://www.24joursdeweb.fr/2018/">&Eacute;dition 2018</a></li>
						<li><a href="https://www.24joursdeweb.fr/2017/">&Eacute;dition 2017</a></li>
						<li><a href="https://www.24joursdeweb.fr/2016/">#nowwwel 2016</a></li>
						<li><a href="https://www.24joursdeweb.fr/2015/">&Eacute;dition 2015</a></li>
						<li><a href="https://www.24joursdeweb.fr/2014/">&Eacute;dition 2014</a></li>
						<li><a href="https://www.24joursdeweb.fr/2013/">&Eacute;dition 2013</a></li>
						<li><a href="https://www.24joursdeweb.fr/2012/">&Eacute;dition 2012</a></li>
					</ul>
				</div>
			</div>
		</footer>
	</div>
			<!--Google Analytics--><div class="textwidget custom-html-widget"><script>
  (function(a,b,c){var d=a.history,e=document,f=navigator||{},g=localStorage,
  h=encodeURIComponent,i=d.pushState,k=function(){return Math.random().toString(36)},
  l=function(){return g.cid||(g.cid=k()),g.cid},m=function(r){var s=[];for(var t in r)
  r.hasOwnProperty(t)&&void 0!==r[t]&&s.push(h(t)+"="+h(r[t]));return s.join("&")},
  n=function(r,s,t,u,v,w,x){var z="https://www.google-analytics.com/collect",
  A=m({v:"1",ds:"web",aip:c.anonymizeIp?1:void 0,tid:b,cid:l(),t:r||"pageview",
  sd:c.colorDepth&&screen.colorDepth?screen.colorDepth+"-bits":void 0,dr:e.referrer||
  void 0,dt:e.title,dl:e.location.origin+e.location.pathname+e.location.search,ul:c.language?
  (f.language||"").toLowerCase():void 0,de:c.characterSet?e.characterSet:void 0,
  sr:c.screenSize?(a.screen||{}).width+"x"+(a.screen||{}).height:void 0,vp:c.screenSize&&
  a.visualViewport?(a.visualViewport||{}).width+"x"+(a.visualViewport||{}).height:void 0,
  ec:s||void 0,ea:t||void 0,el:u||void 0,ev:v||void 0,exd:w||void 0,exf:"undefined"!=typeof x&&
  !1==!!x?0:void 0});if(f.sendBeacon)f.sendBeacon(z,A);else{var y=new XMLHttpRequest;
  y.open("POST",z,!0),y.send(A)}};d.pushState=function(r){return"function"==typeof d.onpushstate&&
  d.onpushstate({state:r}),setTimeout(n,c.delay||10),i.apply(d,arguments)},n(),
  a.ma={trackEvent:function o(r,s,t,u){return n("event",r,s,t,u)},
  trackException:function q(r,s){return n("exception",null,null,null,null,r,s)}}})
  (window,"UA-4722865-4",{anonymizeIp:true,colorDepth:true,characterSet:true,screenSize:true,language:true});
</script></div>		<script type='text/javascript' src='https://www.24joursdeweb.fr/wp-includes/js/wp-embed.min.js?ver=4.9.16'></script>
<script async="async" type='text/javascript' src='https://www.24joursdeweb.fr/wp-content/plugins/akismet/_inc/form.js?ver=4.1.7'></script>
</body>
</html>

<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1607794180 -->